Print
Hits: 10599

Installing WebSphere and the Update Installer

Check out www.itjunglecom for other articles

Hey, Brian:

I followed your directions explicitly regarding your instructions to me as to how to install WebSphere Application Server 6.0 on our new i5. I must admit that the process was so foreign to me that I had no clue as to what was happening, but by following your directions it all seemed to work. But I still have a problem.

 

You don't know how happy I was when well after an hour of running that QSHELL SCRIPT to install WAS 6.0 Express, it finished scrolling all its messages and it made me feel that all was well. To be sure, of course I did a GO LICPGM option 10 to be sure it was in the list. It shows the two parts and I know that it is installed now.

5733W60 *INSTALLED WebSphere Application Server for OS/400 V6
5733W60 *INSTALLED WebSphere Application Server V6 Express
5722JV1 *COMPATIBLE Java Developer Kit 1.4

I appreciated all of your advice to get this installed. I am thankful that we installed the Java Development Kit at level 1.4 as you instructed, since I now realize that you need this to run WAS Express at Version 6.0.X

Though you were kind enough to list for me the PTFs that were required for the WAS 6.0 to run, you did not give detailed instructions as to how to apply the PTFs. Your note suggested that

For WAS 6.0 at V5R3, you need the following:

This includes the following other Group PTFs, which are necessary for WAS 6.0 to function:

I went ahead and did exactly as you suggested, and applied these PTFs and the cumulative PTF pack, as we do all PTFs. Though all seemed well and right after this long process was over, I recalled you saying that there was no autostart entry in the new WAS 6.0 and I got confused as to how to start this all up.

Before I was going to bother you again, I went to IBM's 6,000 pages of PDF Web documentation that you referenced in your prior article and I was tickled that the installation manual was only 66 pages.

As I was reading about the PTFs and trying to assure myself that all was OK with my installation, I came across something that I absolutely do not understand and that is the purpose of this question. What is this Update Installer process that the installation guide refers to and why do I need it. For your convenience, I included the text that confuses me immediately below. Please help me understand what to do about this. It is very confusing.

"When you install the group PTF, the latest fix pack (or refresh pack) is placed in the product installation directory. You must then install the fix pack (or refresh pack). To install the fix pack (or refresh pack), run the update script, which is located in the /QIBM/ProdData/WebSphere/AppServer/V6/edition/updateinstaller directory, where edition is: v Base, if you have WebSphere Application Server--Express, WebSphere Application Server for Developers, or WebSphere Application Server installed; it is v ND if you have WebSphere Application Server Network Deployment installed. For detailed instructions on how to install the fix pack (or refresh pack) after you install the group PTF, see the os400_readme_updateinstaller.html file located in the updateinstaller directory once the PTF has been applied. The fix pack (or refresh pack) installation instructions are also included in the group PTF information file.
See the PTFs page."

Please help me.

--Marlene

 

For the solution part of this article, please take this link to IT Jungle